Developer Portal Access and Billing Issues

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 03:54 UTC

Identified

The issue has been identified, and user impact has been mitigated.
Posted Sep 02, 2025 - 01:34 UTC

Investigating

We are currently investigating an issue where some users are not able to access the developer portal.
Posted Sep 02, 2025 - 00:43 UTC