Elevated 530 errors on api.helius.xyz and api-mainnet.helius-rpc.com from US East

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 10:12 UTC

Identified

This is due to routing issues at a Cloudflare PoP affecting a subset of traffic. We strongly recommend switching to https://beta.helius-rpc.com, which bypasses Cloudflare.

Note: the Webhooks REST API (/v0/webhooks) is not yet supported on beta.
Posted Apr 17, 2026 - 15:15 UTC
This incident affected: Enriched APIs and Webhooks.