Elevated Latency and 504s for Devnet

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 18:36 UTC

Monitoring

Fix has been implemented and latencies are returning to normal.
Posted Jul 09, 2026 - 18:29 UTC

Investigating

We are currently investigating this issue.
Posted Jul 09, 2026 - 18:17 UTC
This incident affected: RPC.