Elevated latency and timeouts for RPC requests from US east

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 19:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 21, 2025 - 18:25 UTC

Investigating

We are currently observing elevated latency and intermittent timeouts on RPC requests routed through the US-East region. This is due to ongoing Cloudflare network performance issues in Ashburn (IAD).
Posted Aug 21, 2025 - 18:00 UTC
This incident affected: RPC.