Elevated Latency and Timeouts in the FRA Region

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 13:47 UTC

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 13:08 UTC
This incident affected: RPC.