We have identified an issue impacting customer usage metrics on the dashboard.

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 04:30 UTC

Identified

We have identified an issue impacting customer metrics on the dashboard; otherwise, all services are operational, and we are restoring metrics.
Posted Sep 05, 2025 - 22:28 UTC