Planned Solana DEVNET cluster restart

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 04:51 UTC

Monitoring

The Solana DEVNET cluster has been halted due to a planned restart to rollback some feature gates. You may see stale data or increased errors as the restart progresses.
Posted Apr 14, 2026 - 04:19 UTC
This incident affected: RPC.