Increased Latency and Connectivity issues in EWR

Incident Report for Helius

Resolved

This incident has been resolved all EWR traffic and connectivity has recovered and routed back.
Posted Jul 08, 2026 - 18:44 UTC

Update

This incident has been resolved all EWR traffic and connectivity has recovered and routed back.
Posted Jul 08, 2026 - 18:44 UTC

Monitoring

The network connectivity has been partially restored, we are still monitoring until failures are fully gone and the issue is fully confirmed resolved.
Posted Jul 08, 2026 - 18:06 UTC

Investigating

We are currently investigating network connectivity issues in the EWR region
Posted Jul 08, 2026 - 17:33 UTC
This incident affected: RPC and LaserStream.