Elevated latency and 504 errors for requests routed through Singapore

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Jul 18, 2026 - 02:42 UTC

Monitoring

A power outage in our SGP data center is the root cause. We've routed traffic away from the affected DC, so you may see elevated latency on Singapore-routed requests in the meantime. All other regions are unaffected.
Posted Jul 18, 2026 - 00:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2026 - 23:52 UTC
This incident affected: RPC, DAS, Atlas (Enhanced Websockets), and LaserStream.