Elevated 500's for getSignaturesForAddress and getTransactionsForAddress

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 01:09 UTC

Monitoring

Fix has been deployed and traffic is returning to normal.
Posted Jan 15, 2026 - 01:09 UTC

Identified

Elevated 500's for getSignaturesForAddress and getTransactionsForAddress, working on a fix. ETA to fix ~5 mins
Posted Jan 15, 2026 - 00:43 UTC
This incident affected: RPC.