Increased error rate on Devnet

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 05:31 UTC

Identified

We have identified an issue that is impacting the shared Devnet cluster, we have deployed a fix and waiting for the issue to resolve.
Posted Apr 10, 2026 - 01:21 UTC