Elevated Latency and 504 Errors (US-West)

Incident Report for Helius

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 16:18 UTC

Monitoring

Issue was mitigated yesterday at 7PM PDT (2AM UTC+1) by working around the CloudFlare degradation.

If you are still experiencing issues, we recommend switching to our new edge gateway, Gatekeeper: "https://beta.helius-rpc.com". Gatekeeper is now recommended for production.
Posted Jun 15, 2026 - 15:43 UTC

Identified

We've identified a likely upstream issue with Cloudflare and have escalated to them. As a workaround, switch from the mainnet endpoint to beta.helius-rpc.com, which does not route through Cloudflare.
Posted Jun 14, 2026 - 21:44 UTC

Investigating

We are currently investigating this issue.
Posted Jun 14, 2026 - 20:58 UTC
This incident affected: RPC, DAS, and Enriched APIs.